Llawan
Allegorie de l'antipathie

Forge : proposez vos améliorations pour MV
le 28/05/2003 1:58
Les deux precedente ayant disparut voici une nouvelle forge pour M-V .
le but de la forge est que vous autres magic-villois postiez des idée d'amelioration pour le site qui selon leur pertinence seront etudié puis peut etre mise en application a vos neurones forgez !
haut de page - Les forums de MV >> Général >> Discussion : page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 | 47 | 48
tatanka
Apôtre de la justice

Minotaure
le 16/10/2019 21:55
Je rajoute l'image de ce que je vois

https://www.zupimages.net/up/19/42/klij.jpg
Marseille, Grèce

Légende
Réponses à jadelpico, canar et tatanka
le 16/10/2019 22:51
jadelpico a écrit :
Je n'ai peut-etre pas bien cherché,mais je ne trouve pas le moyen d'aller vers certaines pages du site.

La page des Challengers decks

Le magnifique jumblemoph de Unstable

Le forum storyline


Bien vu, j'ai ajouté les liens pour les challengers decks sur la page des éditions, les liens Jumblemorph et Contraptions (cadeau) sur la page de Unstable et un lien vers le forum dans l'introduction de la storyline.

canar a écrit :
Ce serait chouette que l'input pour chercher une carte, en haut à droite du site, soit actif par défaut. Un exemple : wordreference.com (ceci n'est pas une pub :D).]Ce serait chouette que l'input pour chercher une carte, en haut à droite du site, soit actif par défaut. Un exemple : wordreference.com (ceci n'est pas une pub :D).


Je l'ai fait, mais je suis sûr que ça va interférer avec d'autres pages qui ont un autofocus. Je n'en ai pas trouvé, mais si vous en voyez, faites signe, je trouverai une solution.

tatanka a écrit :
Salut est-ce que le bug est visible par tous ou uniquement chez moi?


Alors non, le bug est ancien et a été rapporté mille fois. Mais personne n'a été en mesure de me donner un MO reproductible qui crée le bug. Du coup, je n'ai à ce jour pas pu trouver la cause du bins, mais comme c'était gonflant à force, j'ai instauré un contrôle indolore à chaque visite d'un deck. Si la maladie des cartes clonées est répérée, le deck est soigné, mais ne s'affichera correctement qu'à partir du PROCHAIN affichage. Si les symptômes persistent, il faut revenir me consulter.
Rekyem
Maender Alkoor
le 16/10/2019 22:58
Hello,

Est-il possible, dans la recherche avancée, d'avoir un filtre pour les cartes présente sur MTGA ? Le format 'Historique'.
tatanka
Apôtre de la justice

Minotaure
le 16/10/2019 23:36
Je sais pas si ça a un rapport, mais parfois j'arrive plus à rajouter des cartes dans la réserve. Du coup je sauvegarde, valide et j'édite depuis la visualisation du deck et là je peux rajouter des cartes dans la réserve.

Et souvent c'est quand je copie un deck pour avoir déjà une base de deck, et construire le reste depuis cette base (parfois sans réserve, et parfois avec).
gritche
France
le 17/10/2019 0:20
Citation :
Alors non, le bug est ancien et a été rapporté mille fois. Mais personne n'a été en mesure de me donner un MO reproductible qui crée le bug. Du coup, je n'ai à ce jour pas pu trouver la cause du bins, mais comme c'était gonflant à force, j'ai instauré un contrôle indolore à chaque visite d'un deck. Si la maladie des cartes clonées est répérée, le deck est soigné, mais ne s'affichera correctement qu'à partir du PROCHAIN affichage. Si les symptômes persistent, il faut revenir me consulter.


Pour moi c'est un problème de "lag".
J'avais réussi à reproduire le bug en cliquant le plus de fois possible sur le bouton "confirmer la sauvegarde". Mais ça n'arrivait que lorsqu'il y avait un temps d'attente de quelques secondes entre le premier clic et la mise à jour proprement dite. Donc ça n'est pas systématique.

Je viens de réessayer avec cette méthode et effectivement la correction fonctionne, on peut le constater grâce à l'historique qui conserve la trace du bug.

Par contre "effacer l'historique" n'a plus l'air de fonctionner chez moi...
Van
Au pays de Pagnol !, Santon-land

Légende
le 17/10/2019 9:18
@JMB, L'autofocus sur la recherche de carte est très bien, merci, mais pas sur la page de l'artgame où l'autofocus sur le champ de réponse était très utile. A mon avis je ne serais pas le seul à penser comme ça. Serait-ce possible de changer l'autofocus sur cette page précise du site ?
Madmox
I guess Warhol wasn't wrong, Fame fifteen minutes long

Légende
le 17/10/2019 11:00
Cartes en double : je pense vraiment que ça vient d'un pb de soumission multiple du formulaire de saisie de deck (clic frénétique sur le bouton "confirmer la sauvegarde"), et que le bug doit survenir quand les astres sont alignés (accès concurrents en bdd, donc pas reproductible de manière déterministe). D'ailleurs l'action prend des plombes depuis un certain temps (peut-être depuis la mise en place de l'historique, mais pas sûr), genre parfois 10 ou 20 secondes pour un deck de 60 cartes.

Il faudrait a minima désactiver le bouton de soumission du formulaire une fois qu'on a cliqué dessus. C'est d'ailleurs le comportement par défaut avec un formulaire HTML classique + bouton submit, donc j'imagine que ce formulaire là est "custom" et qu'il fait sauter ce comportement.

Au passage, l'historique est réinitialisé quand on importe une nouvelle liste pour un même deck. J'ai l'habitude de bosser mes listes dans Cockatrice puis de les importer périodiquement dans MV au fil des modifs, ce qui fait que je n'ai aucun historique quand je fais ça ^^
canar

Légende
le 17/10/2019 11:06
Merci pour l'autofocus :)
ZeSword
Bruxelles, Belgique

AVATAR
Madmox
le 17/10/2019 12:01
Madmox a écrit :
Au passage, l'historique est réinitialisé quand on importe une nouvelle liste pour un même deck. J'ai l'habitude de bosser mes listes dans Cockatrice puis de les importer périodiquement dans MV au fil des modifs, ce qui fait que je n'ai aucun historique quand je fais ça ^^

Lien "Importer une liste" depuis un deck a écrit :
Si vous utilisez cette boîte, l'historique des modifications du deck sera effacé lors de la sauvegarde.
Madmox
I guess Warhol wasn't wrong, Fame fifteen minutes long

Légende
le 17/10/2019 14:48
Alors certes j'étais passé à côté de la notif, mais ça ne change rien au problème ^^ Enfin c'est pas capital non plus.
Marseille, Grèce

Légende
le 17/10/2019 15:10
Citation :
@JMB, L'autofocus sur la recherche de carte est très bien, merci, mais pas sur la page de l'artgame où l'autofocus sur le champ de réponse était très utile. A mon avis je ne serais pas le seul à penser comme ça. Serait-ce possible de changer l'autofocus sur cette page précise du site ?


Chez moi, il restait sur le champ de réponse, ça doit dépendre des navigateurs. Je l'ai viré de la recherche de cartes pour l'artgame, si vous en voyez d'autres ...
xbod
Modérateur section EDH
Minotaure
le 20/10/2019 18:24
Dernièrement quand on clique sur la watch ou sur le dernier message, sous chrome en tout cas, on ne descends plus automatiquement au dernier message ou celui cliqué dans la watch.

Il faut tout scroll à la main :P
Van
Au pays de Pagnol !, Santon-land

Légende
le 20/10/2019 19:27
Ce n'est pas que sur Chrome, sur Firefox aussi, c'est su à l'autofocus sur le champ de recherche de carte en haut à droite. C'est vrai que lorsqu'on clique sur le lien pour accéder au dernier message d'un sujet on ne veut pas rechercher de carte. Je ne sais par contre pas du tout ce qu'il est possible de faire pour améliorer ça.

le 20/10/2019 19:37
Je n'ai pas ce soucis. Pas d'auto-focus quand je clique sur le lien pour accéder au dernier message d'un sujet ou dans la watch. Ca me positionne correctement sur la bonne #ancre et je n'ai pas d'autofocus sur le champs de recherche.
xbod
Modérateur section EDH
Minotaure
le 20/10/2019 19:38
C'est quoi l'auto focus ?

le 20/10/2019 19:49
Le fait que lorsque tu ouvre une (certaines?) page magic-ville, tu sois par défaut dans le champs de recherche de carte et peut directement y taper ta recherche afin de trouver une carte. Bref, un truc pour fainéant qui sont pas fichu de cliquer dans un champs texte.
ZeSword
Bruxelles, Belgique

AVATAR
Effectivement
le 20/10/2019 20:44
L'ancre ne fonctionne pas toujours, et je n'ai pas réussi à trouver exactement ce qui fait que ça fonctionne ou pas. Par ex. sur un fil donné, j'arrive à avoir des posts dont l'ancre fonctionne et des posts pour lesquels l'ancre ne fonctionne pas (Firefox). Du coup ce n'est peut-être pas forcément lié à l'autofocus ?
kricheck2001
Médite
Pégase
le 20/10/2019 20:47
Par defaut mon ancre se trouve dans le champ recherche de carte :x
Marseille, Grèce

Légende
le 20/10/2019 21:01
J'ai désactivé l'autofocus quand on est clique sur un sujet du forum, ça devrait éviter les conflits et ça parait plutôt pertinent.
xbod
Modérateur section EDH
Minotaure
le 20/10/2019 22:30
ça rememarche, merci les gars :)
haut de page - Les forums de MV >> Général >> Discussion : page 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 | 47 | 48
Vous devez être identifié pour pouvoir poster sur les forums.